Routeros V6 40.3

Posted on  by 



  1. Routeros V6 40.3 For Sale
  2. Routeros V6.40.4
40.3
mikrotik-dweet-stats
#
# MikroTik RouterOS Script
# This script has two parts: 1) RouterOS statistics collector 2) Push router stats up to dweet.io
#
# This script can be adapted to send the collected statistics to any NMS system that supports
# receiving data via http get/post requests.
#
# Tested on RouterOS v6.40.3
# Learn more about this script and dweet.io by reading...
# http://jcutrer.com/howto/networking/mikrotik/mikrotik-script-dweet-io-stats
#
# Script Revision: 1.0.2
# Author Name: Jonathan Cutrer
# Author URL: http://jcutrer.com
#
# Change Log
#
# 1.0.2 Reworked stats collection in groups, you can turn each on/off below
# Changed dweet.io call to use SSL (https://)
# Added VPN stats collection
# Added Health stats collection
# Added Routing Protocol stats collection
#
# 1.0.1 Added keep-result=no to last line
#
# 1.0.0 Initial Release
#
#
# Begin Setup
#
:local interfaceWAN 'pppoe-out1';
:local interfaceWLAN 'wlan2';
:local interfaceWLANGuest 'wlan2.2';
:local prefix 'mikrotik-stats';
:local dweetURL 'https://dweet.io/dweet/quietly/for/';
:local dataParams;
#
# Collection Groups
# Define what gets groups of statistics get collected and sent
#
:local enBoard true
:local enPerf true
:local enHealth true
:local enRouter true
:local enRouting true
:local enFirewall true
:local enWireless true
:local enVPN true
#
# End Setup
#
# Collect Stats: Board
#
:local boardData; :local identity; :local model; :local serial;
if ( $enBoard ) do={
:put 'Collecting Board data...'
:set identity [/system identity get name];
:set model [/system routerboard get model];
:set serial [/system routerboard get serial-number];
:set boardData 'identity=$identity&serial=$serial'
:set dataParams $boardData;
}
# Set the thing name
:local thing '$prefix-$serial'
#
# Collect Stats: Perf
#
:local perfData; :local cpuLoad; :local memFree; local memTotal; :local uptime;
if ( $enPerf ) do={
:put 'Collecting Performance data...'
:delay 5
:set cpuLoad [/system resource get cpu-load];
:set memFree [/system resource get free-memory];
:set memTotal [/system resource get total-memory];
:set uptime [/system resource get uptime];
:set perfData 'cpu-load=$cpuLoad&uptime=$uptime&mem-free=$memFree&mem-total=$memTotal'
:set dataParams ( $dataParams . '&' . $perfData);
}
#
# Collect Stats: Wireless
#
:local wirelessData; :local wlanClients; :local wlanGuests;
if ( $enWireless ) do={
:put 'Collecting Wireless data...';
:set wlanClients [/interface wireless registration-table print count-only where interface='$interfaceWLAN'];
:set wlanGuests [/interface wireless registration-table print count-only where interface='$interfaceWLANGuest'];
:set wirelessData 'wlan-clients=$wlanClients&wlan-guests=$wlanGuests';
:set dataParams ( $dataParams . '&' . $wirelessData);
}
#
# Collect Stats: Firewall
#
:local firewallData; :local ipFwConx;
if ( $enFirewall ) do={
:put 'Collecting Firewall data...';
:set ipFwConx [/ip firewall connection tracking get total-entries];
:set firewallData 'ip-fw-conx=$ipFwConx';
:set dataParams ( $dataParams . '&' . $firewallData);
}
#
# Test Output of Collected Data
#
:put $boardData
:put $perfData
:put $wirelessData
:put $firewallData
#
# Build the Final Request URL
#
:local finalURL;
:set finalURL '$dweetURL$thing?$dataParams'
# print the final url
:put $finalURL
#
# Push data to dweet.io
#
/tool fetch url='$finalURL' mode=https keep-result=no
# end of script
Sign up for freeto join this conversation on GitHub. Already have an account? Sign in to comment
  1. Name Last modified Size Description; Parent Directory - CHANGELOG3: 2009-09-18 15:12: 56K: CHANGELOG4: 2011-05-25 21:35.
  2. Defconf - fixed RouterOS default configuration (introduced in v6.40.3); - dhcp - fixed downgrade from RouterOS v6.41 or higher; - dhcpv6 client - added IAID check in reply; - dhcpv6-client - fixed IA check on solicit when 'rapid-commit' is enabled; - dhcpv6-client - ignore unknown IA; - dhcpv6-client.

Routeros V6 40.3 For Sale

6.41rc34 changelog:

*) crs3xx - improved packet processing in slowpath;
*) defconf - fixed RouterOS default configuration (introduced in v6.40.3);
*) ethernet - removed 'master-port' parameter;
*) log - fixed 'unknown' interface name in log messages;
*) lte - added '/interface lte apn' menu (Passthrough requires reconfiguration) (CLI only);
*) lte - do not reset modem when it is not possible to access SMS storage;
*) snmp - fixed 'ifHighSpeed' value of VLAN, VRRP and Bonding interfaces;
*) snmp - fixed '/caps-man registration-table' uptime values;
*) tile - improved hardware encryption processes;
*) vlan - do not allow VLAN MTU to be higher than L2MTU;
*) wireless - fixed rate selection process when 'rate-set=configured' and NV2 protocol is used;
Other changes since 6.40.3:
!) bridge - implemented software based vlan-aware bridges;
https://wiki.mikrotik.com/wiki/Manual:Interface/Bridge#Bridge_VLAN_Filtering
!) switch - 'master-port' conversion into a bridge with hardware offload 'hw' option;
https://wiki.mikrotik.com/wiki/Manual:Switch_Chip_Features#Bridge_Hardware_Offloading
!) bridge - general development of hw-offload bridge implementation (introduced in v6.40rc36);
*) address - show warning on IPv6 address when acquire from pool has failed;
*) arp - fixed invalid static ARP entries after reboot on interfaces without IP address;
*) arp - properly update dynamic ARP entries after interface related changes;
*) bridge - added initial support for hardware 'igmp-snooping' on CRS1xx/2xx;
*) bridge - automatically turn off 'fast-forward' feature if both bridge ports have 'H' flag;
*) bridge - changed 'Host' and 'MDB' table column order;
*) bridge - fixed 'fast-forward' counters;
*) bridge - fixed 'R' state for bridge interfaces on x86 and CHR installations (introduced in v6.41rc12);
*) bridge - fixed ARP setting (introduced in v6.40rc36);
*) bridge - fixed connectivity issues when there are multiple VLAN interfaces on bridge;
*) bridge - fixed multicast forwarding (introduced in v6.40rc36);
*) bridge - implemented dynamic entries for active MST port overrides;
*) bridge - implemented software based 'igmp-snooping';
*) bridge - implemented software based MSTP;
*) bridge - removed 'frame-types' and 'ingress-filtering' for bridge interfaces (introduced in v6.40rc36);
*) bridge - show 'admin-mac' only if 'auto-mac=no';
*) bridge - show bridge interface local addresses in the host table;
*) btest - improved reliability on Bandwidth Test when device`s RAM is almost full;
*) capsman - added 'vlan-mode=no-tag' option;
*) capsman - return complete CA chain when issuing new certificate;
*) certificate - fixed import of certificates with empty SKID;
*) certificate - fixed SCEP 'get' request URL encoding;
*) certificate - show 'Expired' flag when initial CRL fetch fails;
*) chr - added KVM memory balloon support;
*) chr - added suspend support;
*) console - do not stop '/certificate sign' process if console times out in 1 minute;
*) crs1xx/2xx - fixed 1 Gbps forced mode for several SFP modules;
*) crs317 - added initial support for HW offloaded MPLS forwarding;
*) crs317 - added L2MTU support;
*) crs326 - fixed packet processing speed on switch chip if individual port link speed differs;
*) crs3xx - added port ingress and egress rate limiting;
*) CRS3xx - switch VLAN configuration integrated within bridge VLAN configuration with hw-offload;
*) dhcp - fixed DHCP services failing after reboot when DHCP option was used;
*) dhcp - fixed unresponsive DHCP service caused by inability to read not set RAW options;
*) dhcp - require DHCP option name to be unique;
*) dhcpv4-client - allow to use DUID for client as identity string as the option 61;
*) dhcpv6 client - added IAID check in reply;
*) dhcpv6-client - fixed IA check on solicit when 'rapid-commit' is enabled;
*) dhcpv6-client - ignore unknown IA;
*) dhcpv6-client - require pool name to be unique;
*) e-mail - auto complete file name on 'file' parameter (introduced in v6.40);
*) e-mail - do not show errors when sending e-mail from script;
*) eoip - made L2MTU parameter read-only;
*) export - fixed interface list export;
*) export - fixed wireless 'ssid' and 'supplicant-identity' compact export;
*) hotspot - fixed missing '/ip hotspot server profile' if invalid 'dns-name' was specified;
*) hotspot - improved user statistics collection process;
*) ike1 - release mismatched PH2 peer IDs;
*) ike1 - remove PH1 and PH2 when 'mode-config' exchange fails;
*) ike2 - check identities on 'initial-contact';
*) ike2 - use peer configuration address when available on empty TSi;
*) interface - added '/interface reset-counters' command (CLI only);
*) interface - added option to join and exclude '/interface list' from one and another;
*) interface - fixed corrupted '/interface list' configuration after upgrade;
*) ippool6 - try to assign desired prefix for client if prefix is not being already used;
*) ipsec - added DH groups 19, 20 and 21 support for phase1 and phase2 (CLI only);
*) ipsec - allow to specify 'remote-peer' address as DNS name;
*) ipsec - kill PH1 on 'mode-config' address failure;
*) ipsec - renamed 'firewall' argument to 'notrack-chain' in peer configuration;
*) ipv6 - add dynamic '/ip dns' server address from RA when RA is permitted by configuration;
*) ipv6 - fixed IPv6 address request from pool (introduced in v6.41rc1);
*) l2tp-server - fixed PPP services becoming unresponsive after changes on L2TP server with IPSec configuration;
*) lcd - fixed 'flip-screen=yes' state after reboot;
*) lcd - fixed unresponsive LCD (introduced in v6.41rc15);
*) log - added 'bridge' topic;
*) log - optimized 'poe-out' logging topic logs;
*) lte - added Passthrough support (CLI only);
*) lte - added support for ZTE ME3630 E1C with additional '/port' for GPS usage;
*) lte - added Yota non-configurable modem support;
*) lte - automatically add '/ip dhcp-client' configuration on interface;
*) lte - changed default values to 'add-default-route=yes', 'use-peer-dns=yes' and 'default-route-distance=2';
*) lte - fixed mode initialization after reboot;
*) lte - integrated IP address acquisition without DHCP client for wAP LTE kit-US;
*) lte - properly recognize USB devices under '/system resource usb' (introduced in v6.41rc12);
*) modem - added initial support for Alcatel IK40 and Olicard 500;
*) ospf - fixed OSPF v2 and v3 neighbor election;
*) ppp - added support for Sierra MC7750, Verizon USB730L;
*) ppp - fixed missing PPP client interface after reboot (introduced in v6.41rc);
*) ppp - fixed serial port loading (introduced in v6.41rc);
*) ppp - fixed situation when part of PPP configuration was reset to default values after reboot;
*) pppoe - fixed invalid PPPoE server or client after reboot or 'interface' edit (introduced in v6.41rc9);
*) pppoe-server - fixed situation when PPPoE servers become invalid on reboot;
*) rb931-2nd - fixed startup problems (requires additional reboot after upgrade);
*) routerboard - fixed '/system routerboard upgrade' for CRS212-8G-4S;
*) sfp - fixed SFP interface power monitor when bad SFP DDMI information is received;
*) sfp - fixed temperature readings for various SFP modules;
*) sftp - added functionality which imports '.auto.rsc' file or reboots router on '.auto.npk' upload;
*) sniffer - fixed VLAN tag reporting for TX packets (introduced 6.41rc14);
*) snmp - fixed '/system license' parameters for CHR;
*) snmp - fixed bridge host requests on devices with multiple bridge interfaces;
*) tile - improved reliability on MPLS package processing;
*) traceroute - improved '/tool traceroute' results processing;
*) ups - fixed duplicate 'failed' UPS logs;
*) userman - fixed unresponsive RADIUS server (introduced in v6.40.3);
*) webfig - improved reliability of login process;
*) winbox - added 'notrack-chain' setting to IPSec peers;
*) winbox - do not show duplicate 'Template' parameters for filter in IPSec policy list;
*) winbox - do not show duplicate filter parameters 'Published' in ARP list;
*) winbox - fixed bridge port sorting order by interface name;
*) winbox - show warnings under '/system routerboard settings' menu;
*) wireless - added 'allow-signal-out-off-range' option for Access List entries (CLI only);
*) wireless - improved reliability on 'rx-rate' selection process;
*) wireless - log 'signal-strength' when successfully connected to AP;
*) wireless - pass interface MAC address in Sniffer TZSP frames;
*) wireless - updated United Kingdom regulatory domain information;
Download the new 'RouterOS 6.41rc34' version here: https://www.mikrotik.com/download

Routeros V6.40.4

در این پست آخرین نسخه MikroTik RouterOS یعنی ورژن 6.40.5 که در تاریخ 2017-Oct-31 منتشر شده است را قرار می دهیم. این نسخه دارای License سطح 6 می باشد. تغییرات صورت گرفته در این نسخه جزئی می باشد، لیست تغییرات در آخر پست قرار گرفته است.





Coments are closed